当前位置:首页 > 知识>《枪指挥我》完美版指标公式

《枪指挥我》完美版指标公式

公式 完美版2015-01-13 19:32:05
摘要 : 之所以要反复提醒,就是为了帮助坛友准确看盘。...

我的《枪指挥我》主图指标公式自公示以来,经过这段时间的实践和优化,保留了“进攻”、“冲锋号”的追涨提示;而且现在的“瞄准”、“大战役”和“撤退”、“大撤退”也没有未来函数,请放心使用。之所以要反复提醒,就是为了帮助坛友准确看盘。并冠以更确切的底和顶的定义了。
呵呵,就体力而言,请先顶后下……
现在就公示《枪指挥我》完美版的源码和图:

枪指挥我(完美版)20080217源码:
input:P1(3,0,300),P2(8,0,300),P3(20.5,0,300),P4(118,0,300),P5(236,0,9999),N(4,0,5);
VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.998),8);

STICKLINE((VAR2 < MA(VAR3,6)),CLOSE,OPEN,7,1),COLORGREEN;
STICKLINE((VAR2 < MA(VAR3,6)),LOW,(MIN(OPEN,CLOSE) * 1.001),0.6,0),COLORGREEN;
STICKLINE((VAR2 < MA(VAR3,6)),MAX(OPEN,CLOSE),HIGH,0.6,0),COLORGREEN;
STICKLINE((VAR2 > MA(VAR3,6)),OPEN,CLOSE,7,1),color4440FF;
STICKLINE((VAR2 > MA(VAR3,6)),HIGH,MAX(CLOSE,OPEN),0.6,0),color4440FF;
STICKLINE((VAR2 > MA(VAR3,6)),LOW,(MIN(CLOSE,OPEN) * 1.001),0.8,0),color4440FF;
STICKLINE(((OPEN > CLOSE) AND (VAR2 > MA(VAR3,6))),(OPEN * 0.998),(CLOSE * 1.0025),4.5,0),COLORGREEN;
STICKLINE(((OPEN < CLOSE) AND (VAR2 < MA(VAR3,6))),(CLOSE * 0.998),(OPEN * 1.0025),4.5,0),color4440FF;
STICKLINE(((OPEN > CLOSE) AND (VAR2 < MA(VAR3,6))),CLOSE,OPEN,7,0),COLORGREEN;
DRAWTEXT(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.988),'B'),coloryellow,linethick3;
DRAWTEXT(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.02),'S'),COLORGREEN,linethick3;

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,8);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)

快速索引: